lunes, 6 de junio de 2016

Habilitar Soap en PHP



Hola Chic@s,

Les comento que una vez actualizada la versión de php necesitaba de urgencia trabajar con soap, pero no me funcionaba verifica con este comando: rpm -qa php* y verificaba que efectivamente tenía instalado soap:

Pero no funcionaba, así estuve por horas, hasta que encontre la solución que se las comparto:

  1. Identificar donde se encuentra ubicados los módulos de php, use un: locate soap



      2. Esa ruta se debe agregar en el archivo php.ini



      3. Finalmente verifican con el siguiente comando :
         

      Si todo esta ok, debe aparecer la palabra soap.


    Nos vemos chicosss....

   Lü =)


viernes, 3 de junio de 2016

ZendSkeleton must be compatible with that of ArrayAccess::offsetGet()




Hola Chic@s

Hoy les traigo un error de esos que no tienes idea del "por que", empezaré a contar los antecedentes, necesitaba añadir la extension soap en php.. investigando llegue que se debía instalar por lo que ejecute el comando yum install php-soap todo de maravilla, hasta que se me ocurre cargar la página.. pero no no funciona ni la página y me presenta el siguiente error:

Fatal error: Declaration of Zend\Stdlib\ArrayObject::offsetGet() must be compatible with that of ArrayAccess::offsetGet() in /var/www/html/zf2-tutorial/vendor/zendframework/zendframework/library/Zend/Stdlib/ArrayObject.php on line 22

No encontraba la solución hasta que descubrir que al ejecutar ese comando tambien se instalo otra versión de php.. entonces tenía conflictos ya que tenía la 5.3 y 5.4.

La solución fue desinstalar todo de php y reinstalar la 5.4 ejecutando los siguientes comandos:

rpm -aq php *      ---> Este comando presenta todo lo que se tenga instalado de php.
Como se darán cuenta tenía 5.3 y 5.4
Entonces a eliminar se ha dichoooo... con el siguiente comando:
rpm -e "nombre a eliminar"

Y así fui eliminando cada paquete.. quedo limpio.. 
Verifique que en mi repositorio "yum" si tenia php 5.4 ... comence a instalar:



















Una vez finalizada la instalación... no presento más el error .. entonces dije "WE ARE THE CHAMPIONS" JAJA



Se cuidan Chic@s,

Bendiciones,

Lü =)